Skip to Content

WoW Insider has the latest on the Mists of Pandaria!
  • shadowsun
  • Member Since Dec 3rd, 2008

Are you shadowsun? If So, Login Here.

BlogComments
WoW19 Comments

Recent Comments:

Last chance to enter to win a Creative headset of your own {WoW}

Nov 12th 2009 12:22AM Do a barrel roll.

Enter to win your own Creative WoW Wireless headset {WoW}

Oct 28th 2009 5:53PM gogogo gadget ears!

Patch 3.2 in pictures {WoW}

Aug 4th 2009 5:12PM Thank you so much Remen.

Patch 3.2 in pictures {WoW}

Aug 4th 2009 5:09PM No I'm sure I clicked download Universal warcraft client.

Patch 3.2 in pictures {WoW}

Aug 4th 2009 5:07PM OK doing that right now ^_- but yea launcher got uninstalled by my sister when she decided that I didn't need wow one day O_O didnt bother me much since it still ran just fine till I royaly F'd up today.

Patch 3.2 in pictures {WoW}

Aug 4th 2009 5:01PM IDK where else to ask this so I'm going to ask here (went to official forums and recieved no help) I've played Wow this past month without the launcher (Somehow got uninstalled) without issues until patch day. When I would click the shortcut it would take me right to the log-in screen. Well today when I tried to log-in it said that I required the patch to sign-in. That's when I realized that I needed to have the launcher. I got on Blizzards technical support site, and used the repair tool. About half way through repairing I figured "screw it, I'll just reinstall wow online". So I exited out of the repair, and used the online reinstall option (after deleting my current wow files, cause I thought they would interfere with the re-installation). Each install took at max 30 seconds, which I found odd since when I first installed the game each install took bare minimum 1 hour. After they all downloaded the only file that I noticed pop up was a vanilla folder named "World of warcraft". When going through the file I noticed that it only contained a few core files for the game itself. Finding this EXTREMELY odd I then attempted the repair option again whilst calling Blizzard tech support, which told me to carry out what I was doing and to see if it works after the repair. After letting it repair nothing happened and I'm still stuck looking at a vanilla folder with only core files :"( please help.

World of Warcraft Patch 3.2 Release Patch Notes [Updated] {WoW}

Aug 4th 2009 4:57PM Went to the official forums about this and got no help. :"(