Skip to Content

WoW Insider has the latest on the Mists of Pandaria!
  • Suweero
  • Member Since Mar 13th, 2009

Are you Suweero? If So, Login Here.

BlogComments
WoW20 Comments

Recent Comments:

Enter to win a Creative World of Warcraft wireless headset {WoW}

Sep 24th 2009 12:18PM i like big butts and i cannot lie...


come on, please don't make me have to buy one of these...

WoW.com's Guide to Patch 3.2.2 {WoW}

Sep 22nd 2009 2:43PM im sure this question has been asked but i havn't spotted it, any ideas of what type of gear level ones raid should be looking at having before attempting the new onyxia?

Raid Rx: What's a good raid healing makeup? {WoW}

Sep 15th 2009 3:06PM Never knew there was issues with disc using PW:S on tanks until now as my MT is prot warrior and my MH is a disc priest and they never have issues (and like others are saying why would they?).


Got myself a level 65 disc/shadow priest, AV is a lot of fun as disc priest especially if you can find the one guy that everyone is going after and keeping him alive while the other team fruitlessly tries to take him down.

Breakfast Topic: The trouble with instance servers {WoW}

Sep 2nd 2009 11:30AM Im on Tichondrius-US, i have never ever seen "additional instances cannot be launched". when i first heard about it i thought everyone was making it up haha.


SWAPS loot system offers another DKP option {WoW}

Jul 9th 2009 1:48PM Do any guilds use just a standard Mainspec>Offspec type deal anymore?

The way my guild currently runs is Mainspecs roll, no mainspecs then off specs roll and if neither we shard it. Also, 1 token piece per run and generally 1 piece per boss.

I am guessing because i am in a kind of smaller guild is why this works, i just don't see the appeal in using a points systems where after you down a boss you spend 15 minutes sitting around bidding on gear.

The Queue: WoW 4.0 {WoW}

Jul 8th 2009 3:32PM When maintenance is performed on tuesdays what happens to the timer for our posted auctions? Does the timer keep running and get chewed up by maintenance (thus making it better to not post auctions if the timer runs into maintenance) or do they stop the timer when the server is down?

Blood Pact: Return to the depths of the third tree! {WoW}

Jun 4th 2009 2:34PM i havn't noticed that big of a lag when i cast immo to go to conflag. I'd say its a little bit less then 0.5 seconds for me. might depend on server? one thing i have found thats odd is after a while my conflag button will stay active regardless if immo is up or not. This usually happens after a few rounds of the rotation and it does away with the immo to conflag lag.


i started off affliction, switched to demo for 70 - 80 and specced destro after 3.1. I think demo is the way to go for questing as once you get the felguard its quite beastly and is a money tank. Affliction is good as well but with the voidwalker nerf a little while back he is kind of weak now a days, but it is efficient to be able to dot like 3 or 4 mobs and then fear and run around like a chicken with your head cut off while they slowly drain down and your voidy holds aggro.

World of Warcraft on Windows 7 RC {WoW}

May 29th 2009 4:54PM Thanks for the thoughts, greatly appreciated.

A friend recommended taking the 2 1GB chips i have currently in my system and placing them in the opposite slots, IE right now i have them in slots 1 and 3 (physically on the mobo, not what bios lists them as) and it works fine, if i put them in slots 2 and 4 should everything run smoothly assuming everything is working as it should? I figured this would be the best way to determine if the slot on the mobo has crapped out.

World of Warcraft on Windows 7 RC {WoW}

May 29th 2009 4:28PM Hey you guys seem knowledgeable about your hardware can you guys help me out with something?

A few weeks ago I upgraded from 2 GB of RAM (2x 1GB sticks) to 4 GB RAM (4x 1GB sticks). Everything installed great and performance boost was a little noticable. A couple days ago I upgrade my 256MB Geforce 6800 Ultra to a 1GB GeForce 9600GT and I now have run into some problems with the RAM. It seems that my BIOS won't read my second RAM slot now. The weirdest part about it is the first time i booted up i got an error stating that my RAM is not in the proper slots and it won't work optimally. Previous to this my computer beep three times when i turned it on, but now it turns on and when i check the BIOS it says slot 2 nothing installed, and Properties under my computer states im only running 3 GB as opposed to the 3.5 GB it said i had prior to installing the card.

I had some issues installing the RAM (i put the chips in backwards numerous times, thought i cracked off those clips the ram clips in to but i guess they just snap back into place) but could that be the problem or do you think my power supply could be the issue (supposedly running a 520W 12V power supply, card recommended minimum 400W 12v).

I know this is a wall of text and i expect most to skip this, but any help would be appreciated.

The Queue: Eight {WoW}

Mar 13th 2009 3:18PM MMMMmmmm good eats!